Solved: Linksys Velop Bridge Mode Dropping The Connection

 Linksys Velop Bridge Mode Dropping The Connection

If you are having Linksys Velop node set up in bridge mode, then you have the luxury of accessing Wi-Fi from anywhere within your home or workplace. Usually, when set the primary Velop node to bridge mode, all the other nodes will automatically be set to bridge mode as well. Now, if Linksys Velop drops connection while in bridge mode, then immediately check if you see any red light on Velop. If the Linksys velop bridge mode dropping the connection, perform the following troubleshooting steps to fix the issue.

Restart Velop:

  • Turn off your router, modem, and Velop node.
  • Wait for some time and then turn on the devices.
  • Now, check if the connection dropping issue has been fixed.

Reconnect Velop:

  • Turn off Velop and router and remove the connection between them.
  • Check if the Ethernet cable is firmly connected.
  • In case you have a switch in between, then connect Velop directly to your router or modem.
  • Turn on the device and check if the connection dropping issue has been fixed.
  • If you have connected Velop nodes wirelessly, then this issue might occur if one node is not within the range of the other. So, place the nodes accordingly.

Update the Firmware:

  • If the firmware of your Linksys Velop node has not been updated, then the connection dropping issue will occur.
  • To update the firmware, open a browser on your computer connected to Velop.
  • Type the IP address of Velop in the address bar.
  • Enter the Linksys cloud account credentials, then click Sign in.
  • On the left panel, go to the Router Settings section and choose Connectivity.
  • Under the Firmware Update section, click on the Check for Updates button to search for the latest firmware.
  • Make sure the Automatic checkbox is enabled.
  • After updating the firmware, check if you face the connection dropping issue in Velop.

Reset Velop:

  • If the issue persists, then you can reset your Velop node.
  • Locate the Reset button on the node.
  • Hold the button until the light on the node turns red. It will then begin to flash. Now, the Velop node will be reset to factory defaults.
  • Again, connect Velop to your router in bridge mode and check if the issue has been fixed.

Following these steps would have fixed the Linksys Velop bridge mode dropping the connection.

Related Articles

Top